Wednesday, January 02, 2008

Rubygems update

I updated rubygems this morning on a client's server and then the gem command started throwing this error:

/usr/bin/gem:23: uninitialized constant Gem::GemRunner (NameError)

I found this link that had the same issue with rails. I have no clue why the gem command didn't get updated, but I had to make the recommended change to the gem command itself, add: "require 'rubygems/gem_runner' " right after the "require 'rubygems' " command.